vaivis has quit [Read error: Connection reset by peer]
waleee has quit [Ping timeout: 250 seconds]
notzmv has joined #river
snakedye has quit [Ping timeout: 246 seconds]
vaivis has joined #river
<novakane>
ifreund: nice, I'll try to implements the new libwayland function in my clients to see how it goes
<novakane>
never saw that there was an @errorName, that's better than having the enum name
vaivis has quit [Read error: Connection reset by peer]
vaivis has joined #river
lxsameer has joined #river
<novakane>
ifreund: one question, why do you use snake case function name in Lock.zig?
<ifreund>
novakane: got spoiled working on tigerbeetle... I just prefer snake case. Got my fingers crossed that I can convince andrew to make that change to the official style guide
<novakane>
ifreund: get you, I'll also prefer snake case, more readable, so I hope you can convince him to change it too :D
<ifreund>
compare the readability of putAssumeCapacityNoClobber() and put_assume_capacity_no_clobber() at smaller font size or from farther away
<novakane>
yeah I think that the only thing I really hate in the style guide :/
<ifreund>
novakane: also @errorName(error.Foo) is just Foo
<ifreund>
I just don't trust std.fmt and don't want it to print "error.Foo"
talismanick has quit [Ping timeout: 240 seconds]
<novakane>
that nice, I'll use it, not a fan of error.Foo in log message
<novakane>
ifreund: and btw, I'm not usually a fan of c_int but I vote in favor of it in the display functions
vaivis has quit [Ping timeout: 246 seconds]
snakedye has joined #river
<ifreund>
another option there would be to make the functions return the errno enum from zig's std directly
<ifreund>
I don't think I've ever seen any code actually use the "number of things processed" that libwayland returns on success
<novakane>
yeah that would works too, would make code less verbose if errno is already in the bindings, I'd just like to have a switch instead of using try
<novakane>
both are fine for me, both are better that what we currently have imo
<novakane>
so looking at my code, I think I would chose to return the value of os.getErrno(), seems like the cleaner things todo
<ifreund>
a Zig error set would be better really, but figuring out all possible errno values libwayland can return for a given function isn't really feasiable
<novakane>
yeah that why the errno enum is probably the best choice imo
notzmv has quit [Ping timeout: 260 seconds]
snakedye has quit [Read error: Connection reset by peer]
snakedye has joined #river
vaivis has joined #river
waleee has joined #river
vaivis has quit [Read error: Connection reset by peer]
groknull has joined #river
groknull has quit [Remote host closed the connection]
waleee has quit [Quit: WeeChat 3.5]
lxsameer has quit [Ping timeout: 246 seconds]
pkap has joined #river
pkap has quit [Quit: Client closed]
vaivis has joined #river
pkap has joined #river
dbuckley has quit [Ping timeout: 250 seconds]
dbuckley has joined #river
<pkap>
ifreund: I'm quite happy with my PR for layout-pinned mappings now. There is however an open question I'm thinking about. Not sure if this is important to you (or others).