<@john_socha:matrix.org> I just noticed that `embedded_hal::digital::v2::InputPin` is marked as unproven, but `OutputPin` is not. Is there a reason for this difference?
fabic has joined #rust-embedded
dcz has joined #rust-embedded
emerent_ has joined #rust-embedded
emerent_ is now known as emerent
<@eldruin:matrix.org> `InputPin` was not considered proven when it was first added to `embedded-hal`. It will be marked as proven in the next major release and can be considered proven now as well for all practical considerations.
<@henrik_alser:matrix.org> john_socha: Great job! 🙌 Some naming nits: consider prefixing your setter functions with ”set_” and maybe rename the functions that write to the display with ”write_” instead? As for the internal stuff, a more idiomatic way, that also provides a safe api would be to use enums (with value) instead...
... of u8 for your commands and set_regs and do the bitmasking stuff in the command and set_reg functions instead so you can’t accidently write invalid stuff to the display. Or if you wanna keep it as you have now with u8 at least semantically these functions should be marked as unsafe.